lkml.org 
[lkml]   [2017]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
From
Date
On Tue, 2017-04-18 at 10:33 +0200, Greg KH wrote:
> On Tue, Apr 18, 2017 at 01:24:37AM -0700, Chewie Lin wrote:
> > Removed the usb_device_reset(), replace with call to usb_reset_device()
> > directly. Plus it removes the confusing function name and addressed
> > the checkpatch warning as well by swap string in the dev_warn() call with
> > __func__ argument, instead of explicitly calling the function name in
> > the string:
> >
> > WARNING: Prefer using "%s", __func__ to embedded function names
> > #417: FILE: main_usb.c:417:
> > + "usb_device_reset fail status=%d\n", status);
> >
> > total: 0 errors, 1 warnings, 1058 lines checked
> >
> > And after fix:
> >
> > main_usb.c has no obvious style problems and is ready for submission.
> >
> >
> > Signed-off-by: Chewie Lin <linsh@oregonstate.edu>
>
> Your subject line is odd, don't you think? Compare it to other patches
> for this driver and please fix it up and resend.
>
> And there's never a need for a 0/X email for a single patch submission,
> no need to do that again.

And __func__ here is vt6656_probe not usb_reset_device.

usb_reset_device is the function that failed.

\
 
 \ /
  Last update: 2017-04-18 12:33    [W:0.043 / U:5.824 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site