[lkml]   [2017]   [Apr]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 03/17] thermal: cpu_cooling: Replace cpufreq_device with cpufreq_dev
On 11-04-17, 10:33, Eduardo Valentin wrote:
> On Thu, Mar 16, 2017 at 10:59:38AM +0530, Viresh Kumar wrote:
> > Objects of "struct cpufreq_cooling_device" are named a bit
> > inconsistently. Lets use cpufreq_dev everywhere.
> >
> Naming is always a matter of taste.. but I frankly cannot see how this
> patch improves anything here. cpufreq_dev is still misleading.

I wasn't trying to get to a better name, but rather be consistent.

> Here other options:
> cpufreq_cooling_dev: not misleading but, may a bit too long..
> cpufreq_cdev: better, but still, not a char dev

I will go for the second one.


 \ /
  Last update: 2017-04-12 08:17    [W:0.064 / U:0.324 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site