lkml.org 
[lkml]   [2017]   [Apr]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: please use pci_alloc_irq_vectors in thunderx_edac.
On Wed, Apr 12, 2017 at 08:06:00AM +0200, Christoph Hellwig wrote:
> Hi Sergey,
>
> you're new thunderx_edac driver uses pci_enable_msix_exact for no
> good reason. Can you please switch it to use pci_alloc_irq_vectors
> before it gets merged to mainline?

Do we need to mark pci_enable_msix_exact() deprecated or so, or maybe a
checkpatch rule?

It says so in some text file in Documentation:

4.3 Legacy APIs

The following old APIs to enable and disable MSI or MSI-X interrupts should
not be used in new code:

pci_enable_msi() /* deprecated */
pci_disable_msi() /* deprecated */
pci_enable_msix_range() /* deprecated */
pci_enable_msix_exact() /* deprecated */
pci_disable_msix() /* deprecated */

but maybe we should enforce it?

--
Regards/Gruss,
Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.

\
 
 \ /
  Last update: 2017-04-12 11:21    [W:0.073 / U:2.936 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site