lkml.org 
[lkml]   [2017]   [Dec]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 4.4 89/96] spi: SPI_FSL_DSPI should depend on HAS_DMA
Date
On Thu, Dec 07, 2017 at 08:41:14PM +0000, Ben Hutchings wrote:
>On Tue, 2017-11-28 at 11:23 +0100, Greg Kroah-Hartman wrote:
>> 4.4-stable review patch.  If anyone has any objections, please let me know.
>>
>> ------------------
>>
>> From: Geert Uytterhoeven <geert@linux-m68k.org>
>>
>>
>> [ Upstream commit dadab2d4e3cf708ceba22ecddd94aedfecb39199 ]
>>
>> If NO_DMA=y:
>>
>>     ERROR: "bad_dma_ops" [drivers/spi/spi-fsl-dspi.ko] undefined!
>>
>> Add a dependency on HAS_DMA to fix this.
>[...]
>
>This driver did not use DMA before 4.10, so I think this should be
>reverted in the 4.4 and 4.9 branches.

I'll revert it for 4.4 and 4.9, thanks Ben!

--

Thanks,
Sasha
\
 
 \ /
  Last update: 2017-12-09 06:42    [W:0.170 / U:1.504 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site