[lkml]   [2017]   [Dec]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 1/3] mm, numa: rework do_pages_move
On Wed, Dec 13, 2017 at 01:17:03PM +0100, Michal Hocko wrote:
> On Wed 13-12-17 15:07:33, Kirill A. Shutemov wrote:
> [...]
> > The approach looks fine to me.
> >
> > But patch is rather large and hard to review. And how git mixed add/remove
> > lines doesn't help too. Any chance to split it up further?
> I was trying to do that but this is a drop in replacement so it is quite
> hard to do in smaller pieces. I've already put the allocation callback
> cleanup into a separate one but this is about all that I figured how to
> split. If you have any suggestions I am willing to try them out.

"git diff --patience" seems generate more readable output for the patch.

> > One nitpick: I don't think 'chunk' terminology should go away with the
> > patch.
> Not sure what you mean here. I have kept chunk_start, chunk_node, so I
> am not really changing that terminology

We don't really have chunks anymore, right? We still *may* have per-node
batching, but..

Maybe just 'start' and 'current_node'?

Kirill A. Shutemov

 \ /
  Last update: 2017-12-13 13:48    [W:0.052 / U:37.504 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site