[lkml]   [2017]   [Nov]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 05/11] trace-cmd: Rename trace_profile() to trace_profile_int()
On Thu, 23 Nov 2017 18:33:29 +0200
"Vladislav Valtchev (VMware)" <> wrote:

> The purpose of this renaming is to make room for a new trace_profile() function,
> that will handle directly the 'profile' command, following the internal
> convention COMMAND_NAME -> trace_{COMMAND_NAME}.

Couple of things.

1) A change like this should always be directly before the patch that
requires it. This is patch 5, and it's not until patch 8 that this
change is required. Please keep them next to each other. This should
have been patch 7.

2) trace_profile_int() is confusing. I keep thinking it's doing
something with integers. Call it do_trace_profile().


-- Steve

 \ /
  Last update: 2017-11-28 18:05    [W:0.083 / U:1.936 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site