lkml.org 
[lkml]   [2017]   [Nov]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 20/43] x86/entry: Clean up SYSENTER_stack code
On Sat, Nov 25, 2017 at 09:26:38AM -0800, Andy Lutomirski wrote:
> On Sat, Nov 25, 2017 at 9:10 AM, Borislav Petkov <bp@alien8.de> wrote:
> > On Sat, Nov 25, 2017 at 06:03:36PM +0100, Thomas Gleixner wrote:
> >> > Maybe I should rename cpu_tss to cpu_tss_rw in that patch.
> >>
> >> For clarity that would be nice.
> >
> > + a comment stating the alias mapping. It took tglx and me a while on
> > IRC to figure it out. :-)
>
> I'm adding this comment to the top of cpu_entry_area:
>
> + * Every field is a virtual alias of some other allocated backing store.
> + * There is no direct allocation of a struct cpu_entry_area.

Right, thanks! That did take me a few minutes to sort as well :-)

\
 
 \ /
  Last update: 2017-11-27 10:28    [W:0.102 / U:3.420 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site