lkml.org 
[lkml]   [2017]   [Nov]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 2/3] leds: Add driver for Qualcomm LPG
From
Date
On 11/21/2017 12:22 AM, Pavel Machek wrote:
> On Mon 2017-11-20 13:10:33, Bjorn Andersson wrote:
>> On Sun 19 Nov 13:36 PST 2017, Jacek Anaszewski wrote:
>>
>>> Hi Bjorn,
>>>
>>> Thanks for the patch. Please refer to my comments in the code.
>>>
>>> On 11/15/2017 08:13 AM, Bjorn Andersson wrote:
>> [..]
>>>> diff --git a/drivers/leds/Kconfig b/drivers/leds/Kconfig
>>>> index 52ea34e337cd..ccc3aa4b2474 100644
>>>> --- a/drivers/leds/Kconfig
>>>> +++ b/drivers/leds/Kconfig
>>>> @@ -651,6 +651,13 @@ config LEDS_POWERNV
>>>> To compile this driver as a module, choose 'm' here: the module
>>>> will be called leds-powernv.
>>>>
>>>> +config LEDS_QCOM_LPG
>>>> + tristate "LED support for Qualcomm LPG"
>>>> + depends on LEDS_CLASS
>>>
>>> You were mentioning that this driver is for a MFD child block,
>>> so we should probably depend on the parent MFD driver?
>>>
>>
>> There's no build time dependency between the two, so it's not strictly
>> necessary.
>>
>> Adding a dependency on MFD_SPMI_PMIC would indirectly add a dependency
>> on ARCH_QCOM, which limit build testing and stop some static code
>> checkers to check the driver.
>>
>> So, unless you strongly object I would prefer not to mention the
>> MFD.
>
> OTOH, this way even users that can't have qualcom LPG are asked the
> question.
>
> So right way is depends on LEdS_CLASS && (BUILD_TEST || MFD_SPMI_PMIC).

Ack.

--
Best regards,
Jacek Anaszewski

\
 
 \ /
  Last update: 2017-11-21 23:02    [W:0.053 / U:0.340 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site