lkml.org 
[lkml]   [2017]   [Nov]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: "swap_free: Bad swap file entry" and "BUG: Bad page map in process" but no swap configured
I think we tracked it down to the "eptad" kernel option on Broadwell processors. 
Setting "kvm-intel.eptad=0" turned it off.

Chris

On 11/20/2017 03:07 AM, Huaitong Han wrote:
> Hi, Chris
>
> I have met the same issue too, did you have found out the root cause ?
>
> Thanks a lot.
>
> Huaitong Han
>
>
> 2016-10-12 0:02 GMT+08:00 Chris Friesen <chris.friesen@windriver.com>:
>> On 10/08/2016 02:05 AM, Hillf Danton wrote:
>>>
>>> On Friday, October 07, 2016 5:01 AM Chris Friesen
>>>>
>>>>
>>>> I have Linux host running as a kvm hypervisor. It's running CentOS. (So
>>>> the
>>>> kernel is based on 3.10 but with loads of stuff backported by RedHat.) I
>>>> realize this is not a mainline kernel, but I was wondering if anyone is
>>>> aware of
>>>> similar issues that had been fixed in mainline.
>>>>
>>> Hey, dunno if you're looking for commit
>>> 6dec97dc929 ("mm: move_ptes -- Set soft dirty bit depending on pte
>>> type")
>>> Hillf
>>
>>
>> CONFIG_MEM_SOFT_DIRTY doesn't exist in our kernel so I don't think this is
>> the issue. Thanks for the suggestion though.
>>
>> Chris

\
 
 \ /
  Last update: 2017-11-21 16:46    [W:0.044 / U:3.068 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site