lkml.org 
[lkml]   [2017]   [Nov]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [GIT PULL 1/2] bcm2835-dt-fixes-2017-10-06
Hi Loic,

>> With 4.14 I get the following, the address doesn't look right, do you
>> have a link to the serdev patch headed to 4.15?
>>
>> # hciconfig
>> hci0: Type: Primary Bus: UART
>> BD Address: AA:AA:AA:AA:AA:AA ACL MTU: 1021:8 SCO MTU: 64:1
>> DOWN
>> RX bytes:542 acl:0 sco:0 events:11 errors:0
>> TX bytes:77 acl:0 sco:0 commands:17 errors:0
>
>
> HCI link seems ok since you have some events/commands in the stats.
> It could be a firmware issue, missing or at the wrong place (BCM43xxx.hcd).
> Does the hci_bcm request firmware call fail ? (dev_info message).

So it seems it's actually working fine albeit the strange mac addr, no
idea what I was trying before, although there's an error about loading
firmware:

[ 31.035291] Bluetooth: hci0: BCM: chip id 94
[ 31.035801] Bluetooth: hci0: BCM: features 0x2e
[ 31.037483] Bluetooth: hci0: BCM43430A1
[ 31.037498] Bluetooth: hci0: BCM43430A1 (001.002.009) build 0000
[ 31.037694] bluetooth hci0: Direct firmware load for
brcm/BCM43430A1.hcd failed with error -2
[ 31.037704] Bluetooth: hci0: BCM: Patch brcm/BCM43430A1.hcd not found

By adding a firmware [1] to the location it actually now stops
working, although shows up with a hciconfig, and had the following
errors.

[ 26.078038] Bluetooth: hci0: BCM: chip id 94
[ 26.096797] Bluetooth: hci0: BCM: features 0x2e
[ 28.130753] Bluetooth: hci0 command 0x0c14 tx timeout
[ 36.322725] Bluetooth: hci0: BCM: Reading local name failed (-110)

Thanks,
Peter

\
 
 \ /
  Last update: 2017-11-21 11:04    [W:0.102 / U:3.284 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site