lkml.org 
[lkml]   [2017]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH AUTOSEL for 4.9 44/56] ASoC: dwc: Fix PIO mode initialization
On Wed, Nov 15, 2017 at 12:46:37PM +0000, Jose Abreu wrote:
> On 15-11-2017 10:54, Mark Brown wrote:

> > So when did the corresponding change to the dmaengine API go in?

> Looks like this was introduced in a8135d0d79e9 ("dmaengine: core:
> Introduce new, universal API to request a channel") but looking
> at soc-generic-dmaengine-pcm.c I see that this would never work
> anyway because dmaengine_pcm_request_chan_of() also returns
> either zero or -EPROBE_DEFER.

So this just never worked for two reasons.

> >> Also, initialize use_pio variable which was never being set
> >> causing PIO mode to never work.

> > Though if PIO mode never worked presumably this isn't that urgent...

> Yeah, and we also have this. Its my fault, I was using a
> different tree for testing at the time. But if we could backport
> this it would be nice because we and our clients use this PIO
> driver in ARC AXS101 Development Platform. (A side note is that
> the DT bindings were only recently introduced but I think its
> more easier to add the bindings instead of fixing this driver ...).

Why on earth would anyone use audio hardware without DMA in production
(or make it for that matter)? Not that it really matters. Even if
there are users on stable presumably the they're already running with
something like this and it'll just conflict with this if it gets
backported? The whole backport to enable a thing that never worked
aspect of this seems out of scope for stable.
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2017-11-15 14:22    [W:0.105 / U:2.052 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site