lkml.org 
[lkml]   [2017]   [Oct]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 26/33] tracing: Add cpu field for hist triggers
On Fri, 22 Sep 2017 15:00:06 -0500
Tom Zanussi <tom.zanussi@linux.intel.com> wrote:

> A common key to use in a histogram is the cpuid - add a new cpu
> 'synthetic' field for that purpose. This field is named cpu rather
> than $cpu or $common_cpu because 'cpu' already exists as a special
> filter field and it makes more sense to match that rather than add
> another name for the same thing.
>
> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
> ---
> Documentation/trace/events.txt | 18 ++++++++++++++++++
> kernel/trace/trace_events_hist.c | 28 +++++++++++++++++++++++++++-
> 2 files changed, 45 insertions(+), 1 deletion(-)
>
> diff --git a/Documentation/trace/events.txt b/Documentation/trace/events.txt
> index 2cc08d4..f36fa00 100644
> --- a/Documentation/trace/events.txt
> +++ b/Documentation/trace/events.txt
> @@ -668,6 +668,24 @@ The following commands are supported:
> The examples below provide a more concrete illustration of the
> concepts and typical usage patterns discussed above.
>
> + 'special' event fields
> + ------------------------
> +
> + There are a number of 'special event fields' available for use as
> + keys or values in a hist trigger. These look like and behave as if
> + they were actual event fields, but aren't really part of the event's
> + field definition or format file. They are however available for any
> + event, and can be used anywhere an actual event field could be.
> + 'Special' field names are always prefixed with a '$' character to
> + indicate that they're not normal fields (with the exception of
> + 'cpu', for compatibility with existing filter usage):
> +
> + $common_timestamp u64 - timestamp (from ring buffer) associated
> + with the event, in nanoseconds. May be
> + modified by .usecs to have timestamps
> + interpreted as microseconds.
> + cpu int - the cpu on which the event occurred.
> +
>

You were going to update this too.

-- Steve

\
 
 \ /
  Last update: 2017-10-04 20:14    [W:0.745 / U:0.072 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site