lkml.org 
[lkml]   [2017]   [Oct]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 03/18] x86/asm/64: Move SWAPGS into the common iret-to-usermode path
On Thu, Oct 26, 2017 at 7:28 AM, Borislav Petkov <bp@suse.de> wrote:
> On Thu, Oct 26, 2017 at 07:13:32AM -0700, Dave Hansen wrote:
>> I kinda appreciate the verbosity. When I see a jump to such a label, I
>
> Sorry but this and other labels' names are just ridiculously long.
> swapgs_restore_regs_return or swapgs_restore or somesuch are perfectly
> fine.
>

Hmm. I'm kind of tempted to rename it to exit_to_usermode. After
all, it's the thing you call after prepare_exit_to_usermode, and its
preconditions rather nontrivial and are quite likely to become even
less trivial in the future.

\
 
 \ /
  Last update: 2017-10-28 20:19    [W:0.073 / U:22.804 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site