lkml.org 
[lkml]   [2017]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: android/android-4.4 build: 210 builds: 0 failed, 210 passed, 6 warnings (ASB-2017-10-5_4.4-o-release-513-gec888d46d899)
On Tue, Oct 17, 2017 at 4:36 PM, gregkh <gregkh@linuxfoundation.org> wrote:
> On Tue, Oct 17, 2017 at 10:51:22AM +0200, Arnd Bergmann wrote:
>> On Tue, Oct 17, 2017 at 1:27 AM, kernelci.org bot <bot@kernelci.org> wrote:
>> >
>> >
>> > Warnings summary:
>> >
>> > 1 net/wireless/nl80211.c:5096:1: warning: the frame size of 2064 bytes is larger than 2048 bytes [-Wframe-larger-than=]
>> > 1 net/wireless/nl80211.c:3859:1: warning: the frame size of 2168 bytes is larger than 2048 bytes [-Wframe-larger-than=]
>> > 1 net/wireless/nl80211.c:1728:1: warning: the frame size of 5640 bytes is larger than 2048 bytes [-Wframe-larger-than=]
>>
>> Hi Greg,
>>
>> I saw you backported my fix for this is to stable/linux-4.9.y, but I
>> don't see it
>> in 4.4.y. Can you add it here as well, or do you want help resolving a conflict?
>>
>> The upstream commit is b4391db42308 ("netlink: fix
>> nla_put_{u8,u16,u32} for KASAN")
>>
>> > 1 drivers/platform/goldfish/goldfish_pipe_v2.c:340:1: warning: the frame size of 2736 bytes is larger than 2048 bytes [-Wframe-larger-than=]
>> > 1 drivers/platform/goldfish/goldfish_pipe_v2.c:340:1: warning: the frame size of 2720 bytes is larger than 2048 bytes [-Wframe-larger-than=]
>> > 1 drivers/platform/goldfish/goldfish_pipe_v2.c:340:1: warning: the frame size of 1368 bytes is larger than 1024 bytes [-Wframe-larger-than=]
>>
>> This is then the only remaining warning in 4.4. We've discussed it a few times
>> before but not concluded on how to best fix it. The warning exists only in
>> the android trees, mainline and stable don't have it.
>
> If you can backport the fix, I'll take it. As it is, it doesn't apply
> cleanly.

I've sent a patch now. From what I found, none of the stable kernels
need the fix. You had applied the patch I sent some time ago on the
android-4.9 kernel. The same patch fixes the problem for me on the
android-4.4 kernel and applies cleanly, just not on the stable-4.4 kernel
that doesn't need it in the first place.

Arnd

\
 
 \ /
  Last update: 2017-10-17 18:09    [W:0.033 / U:0.168 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site