lkml.org 
[lkml]   [2017]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] mm: rename page dtor functions to {compound,huge,transhuge}_page__dtor
On Tue 17-10-17 14:22:14, Kirill A. Shutemov wrote:
> On Tue, Oct 17, 2017 at 12:22:03PM +0200, Michal Hocko wrote:
> > On Mon 16-10-17 17:19:17, changbin.du@intel.com wrote:
> > > From: Changbin Du <changbin.du@intel.com>
> > >
> > > The current name free_{huge,transhuge}_page are paired with
> > > alloc_{huge,transhuge}_page functions, but the actual page free
> > > function is still free_page() which will indirectly call
> > > free_{huge,transhuge}_page. So this patch removes this confusion
> > > by renaming all the compound page dtors.
> >
> > Is this code churn really worth it?
>
> Getting naming straight is kinda nit. :)

yes

> But I don't feel strong either way.

Me neither, I am just trying to understand why the patch has been
created? Is it a preparation for some other changes? If it was removing
some code it would be much more clear but it actually adds twice as much
as it removes so it doesn't save anything there. It makes the API more
explicit which might be good but is it worth that?
--
Michal Hocko
SUSE Labs

\
 
 \ /
  Last update: 2017-10-17 14:01    [W:0.038 / U:3.984 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site