lkml.org 
[lkml]   [2017]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] mm: rename page dtor functions to {compound,huge,transhuge}_page__dtor
On Tue, Oct 17, 2017 at 12:22:03PM +0200, Michal Hocko wrote:
> On Mon 16-10-17 17:19:17, changbin.du@intel.com wrote:
> > From: Changbin Du <changbin.du@intel.com>
> >
> > The current name free_{huge,transhuge}_page are paired with
> > alloc_{huge,transhuge}_page functions, but the actual page free
> > function is still free_page() which will indirectly call
> > free_{huge,transhuge}_page. So this patch removes this confusion
> > by renaming all the compound page dtors.
>
> Is this code churn really worth it?

Getting naming straight is kinda nit. :)

But I don't feel strong either way.

--
Kirill A. Shutemov

\
 
 \ /
  Last update: 2017-10-17 13:22    [W:0.065 / U:0.780 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site