lkml.org 
[lkml]   [2017]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: linux-next: Tree for Oct 13th (drivers/mfd/lpc_ich -> mtd/spi-nor/intel-spi-platform)
From
Date
Hi all,

+ Arnd, who reported this issue too

Le 14/10/2017 à 02:31, Randy Dunlap a écrit :
> On 10/13/17 14:06, Mark Brown wrote:
>> Changes since 20171012:
>>
>> The rdma tree gained a conflict.
>
>
> on i386:
>
> CONFIG_PCI is not enabled.
>
> ../drivers/mfd/lpc_ich.c: In function 'lpc_ich_init_spi':
> ../drivers/mfd/lpc_ich.c:1137:3: error: implicit declaration of function 'pci_bus_write_config_byte' [-Werror=implicit-function-declaration]
> pci_bus_write_config_byte(bus, p2sb, 0xe1, 0x0);
> ^
> ../drivers/mfd/lpc_ich.c:1138:3: error: implicit declaration of function 'pci_bus_read_config_dword' [-Werror=implicit-function-declaration]
> pci_bus_read_config_dword(bus, spi, PCI_BASE_ADDRESS_0,
> ^
> ../drivers/mfd/lpc_ich.c:1147:5: error: implicit declaration of function 'pci_bus_write_config_dword' [-Werror=implicit-function-declaration]
> pci_bus_write_config_dword(bus, spi, BCR, bcr);
> ^
> ../drivers/mfd/lpc_ich.c: At top level:
> ../drivers/mfd/lpc_ich.c:1246:1: warning: data definition has no type or storage class [enabled by default]
> module_pci_driver(lpc_ich_driver);
> ^
> ../drivers/mfd/lpc_ich.c:1246:1: error: type defaults to 'int' in declaration of 'module_pci_driver' [-Werror=implicit-int]
> ../drivers/mfd/lpc_ich.c:1246:1: warning: parameter names (without types) in function declaration [enabled by default]
> ../drivers/mfd/lpc_ich.c:1239:26: warning: 'lpc_ich_driver' defined but not used [-Wunused-variable]
> static struct pci_driver lpc_ich_driver = {
> ^
> cc1: some warnings being treated as errors
> ../scripts/Makefile.build:313: recipe for target 'drivers/mfd/lpc_ich.o' failed
> make[3]: *** [drivers/mfd/lpc_ich.o] Error 1
>
>
> But that driver depends on PCI, so it should not be built.
> This was caused by:
>
> CONFIG_SPI_INTEL_SPI=y
> CONFIG_SPI_INTEL_SPI_PLATFORM=y
>
> where the latter does this:
>
> config SPI_INTEL_SPI_PLATFORM
> tristate "Intel PCH/PCU SPI flash platform driver" if EXPERT
> depends on X86
> select SPI_INTEL_SPI
> select LPC_ICH
>
> even though CONFIG_PCI is not enabled. That's a no-no.
>
>

I've removed the faulty patch from the spi-nor/next branch of l2-mtd:
https://patchwork.ozlabs.org/patch/805803/

Sorry for that!

Best regards,

Cyrille

\
 
 \ /
  Last update: 2017-10-14 08:16    [W:0.047 / U:5.012 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site