lkml.org 
[lkml]   [2017]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v2 01/11] power: supplies: bq275xx: rename BQ27500 allow for deprecation in future.
From
Date
On 6/1/17 10:59 am, Sebastian Reichel wrote:
> Hi Chris,
>
> On Fri, Dec 23, 2016 at 11:04:57AM +1100, Chris Lapa wrote:
>> From: Chris Lapa <chris@lapa.com.au>
>>
>> The BQ275XX definition exists only to satisfy backwards compatibility.
>>
>> tested: yes
>>
>> Signed-off-by: Chris Lapa <chris@lapa.com.au>
>>
>> [...]
>>
>> static bool bq27xxx_battery_overtemp(struct bq27xxx_device_info *di, u16 flags)
>> {
>> - if (di->chip == BQ27500 || di->chip == BQ27541 || di->chip == BQ27545)
>> + if (di->chip == BQ275XX || di->chip == BQ27541 || di->chip == BQ27545)
>> return flags & (BQ27XXX_FLAG_OTC | BQ27XXX_FLAG_OTD);
>> if (di->chip == BQ27530 || di->chip == BQ27421)
>> return flags & BQ27XXX_FLAG_OT;
>
> This is really getting out of hands in this patchset. Please
> add a patch at the beginning of the patchset, which converts
> this construct into the following:
>
> switch (di->chip) {
> case A:
> case B:
> case C:
> case D:
> return flags & (BQ27XXX_FLAG_OTC | BQ27XXX_FLAG_OTD);
> case E:
> case F:
> return flags & BQ27XXX_FLAG_OT;
> default:
> return false;
> }
>
> -- Sebastian
>

I was advised to move these tests into a function which I've done in the
10th patch. I have no issue with changing it to a switch statement, but
should I drop the bq27xxx_has_multiple_overtemp_flags() function I added?

\
 
 \ /
  Last update: 2017-01-06 01:30    [W:0.114 / U:4.736 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site