lkml.org 
[lkml]   [2017]   [Jan]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [PATCH v4 04/15] mtd: nand: rename nand_get_flash_type() into nand_detect()
From
Date
On 01/03/2017 02:01 PM, Boris Brezillon wrote:
> The only caller of nand_get_flash_type() (nand_scan_ident()) actually
> don't use the returned nand_flash_dev pointer except for converting it to
> to an error code.
> Rename this function nand_detect() and make it return an integer.

Ummmm, it did return an integer before though ? The commit message is
kinda cryptic, really.

> Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>
> ---
> drivers/mtd/nand/nand_base.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
> index 3a31b705af6f..efb3ade568d8 100644
> --- a/drivers/mtd/nand/nand_base.c
> +++ b/drivers/mtd/nand/nand_base.c
> @@ -4010,8 +4010,7 @@ static bool find_full_id_nand(struct nand_chip *chip,
> /*
> * Get the flash and manufacturer id and lookup if the type is supported.
> */
> -static int nand_get_flash_type(struct nand_chip *chip,
> - struct nand_flash_dev *type)
> +static int nand_detect(struct nand_chip *chip, struct nand_flash_dev *type)
> {
> struct mtd_info *mtd = nand_to_mtd(chip);
> int busw;
> @@ -4368,7 +4367,7 @@ int nand_scan_ident(struct mtd_info *mtd, int maxchips,
> nand_set_defaults(chip);
>
> /* Read the flash type */
> - ret = nand_get_flash_type(chip, table);
> + ret = nand_detect(chip, table);
> if (ret) {
> if (!(chip->options & NAND_SCAN_SILENT_NODEV))
> pr_warn("No NAND device found\n");
>


--
Best regards,
Marek Vasut

\
 
 \ /
  Last update: 2017-01-04 17:54    [W:0.288 / U:0.400 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site