lkml.org 
[lkml]   [2017]   [Jan]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and px regulator resource.
On Mon 30 Jan 07:03 PST 2017, Avaneesh Kumar Dwivedi wrote:

> This patch add additional clock and regulator resource which are
> initialized based on compatible and has no impact on existing driver
> working. This resourse addition enable the existing driver to handle.
> low pass sensor processor device also.
>
> Signed-off-by: Avaneesh Kumar Dwivedi <akdwived@codeaurora.org>

Applied, with below modification.

> ---
> drivers/remoteproc/qcom_adsp_pil.c | 43 +++++++++++++++++++++++++++++++-------
> 1 file changed, 36 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/remoteproc/qcom_adsp_pil.c b/drivers/remoteproc/qcom_adsp_pil.c
[..]
> static int adsp_init_regulator(struct qcom_adsp *adsp)
> {
> - adsp->cx_supply = devm_regulator_get(adsp->dev, "cx");
> + adsp->cx_supply = devm_regulator_get(adsp->dev, "vdd_cx");

We should not change the name of devicetree properties, so I dropped
"vdd_" on both of these.

> if (IS_ERR(adsp->cx_supply))
> return PTR_ERR(adsp->cx_supply);
>
> regulator_set_load(adsp->cx_supply, 100000);
>
> + adsp->px_supply = devm_regulator_get(adsp->dev, "vdd_px");
> + if (IS_ERR(adsp->px_supply))
> + return PTR_ERR(adsp->px_supply);

Regards,
Bjorn

\
 
 \ /
  Last update: 2017-01-31 06:47    [W:0.082 / U:0.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site