lkml.org 
[lkml]   [2017]   [Jan]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH 5/6] treewide: use kv[mz]alloc* rather than opencoded variants
On Sat 14-01-17 12:56:32, Leon Romanovsky wrote:
[...]
> Hi Michal,
>
> I don't see mlx5_vzalloc in the changed list. Any reason why did you skip it?
>
> 881 static inline void *mlx5_vzalloc(unsigned long size)
> 882 {
> 883 void *rtn;
> 884
> 885 rtn = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
> 886 if (!rtn)
> 887 rtn = vzalloc(size);
> 888 return rtn;
> 889 }

No reason to skip it, I just didn't see it. I will fold the following in
if you are OK with it
---
diff --git a/include/linux/mlx5/driver.h b/include/linux/mlx5/driver.h
index cdd2bd62f86d..5e6063170e48 100644
--- a/include/linux/mlx5/driver.h
+++ b/include/linux/mlx5/driver.h
@@ -874,12 +874,7 @@ static inline u16 cmdif_rev(struct mlx5_core_dev *dev)

static inline void *mlx5_vzalloc(unsigned long size)
{
- void *rtn;
-
- rtn = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
- if (!rtn)
- rtn = vzalloc(size);
- return rtn;
+ return kvzalloc(GFP_KERNEL, size);
}

static inline u32 mlx5_base_mkey(const u32 key)
--
Michal Hocko
SUSE Labs

\
 
 \ /
  Last update: 2017-01-16 08:34    [W:1.290 / U:0.960 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site