lkml.org 
[lkml]   [2017]   [Jan]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH V3 0/5] PCI: exynos: cleans the minor things
Date
Current pci-exynos.c is used for only EXYNOS5440.
It's too complex to support the other Exynos SoCs.
Before supporting the other Exynos SoCs, it needs to clean the codes.

Changelog on V3:
- Splits "PCI: exynos: replace to one register accessor from each accessors"

Changelog on V2:
- Changes the all pointer names as "ep" instead of "exynos_pcie"

Jaehoon Chung (5):
PCI: exynos: Rename all pointer names from "exynos_pcie" to "ep"
PCI: exynos: Replace the *_blk/*_phy/*_elb accessors
PCI: exynos: Remove the unnecessary variables
PCI: exynos: Use the bitops API to operate the bit shifting
PCI: exynos: remove the duplicated codes

drivers/pci/host/pci-exynos.c | 392 +++++++++++++++++++-----------------------
1 file changed, 181 insertions(+), 211 deletions(-)

--
2.10.2

\
 
 \ /
  Last update: 2017-01-16 07:32    [W:0.132 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site