lkml.org 
[lkml]   [2017]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations
Hi Markus,

On Wed, 11 Jan 2017 21:34:13 +0100
SF Markus Elfring <elfring@users.sourceforge.net> wrote:

> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Wed, 11 Jan 2017 21:21:12 +0100
>
> Several update suggestions were taken into account
> from static source code analysis.
>
> Markus Elfring (18):
> Use kmalloc_array() in cfi_intelext_partition_fixup()
> Improve another size determination in cfi_intelext_partition_fixup()
> cfi_cmdset_0001: Add some spaces for better code readability
> cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword()
> cfi_cmdset_0001: Use common error handling code in do_write_oneword()
> Use kcalloc() in cfi_intelext_setup()
> One function call and an unnecessary check less in cfi_intelext_setup()
> Rename a jump label in cfi_intelext_setup()
> Use kmalloc_array() in cfi_amdstd_setup()
> One function call less in cfi_amdstd_setup() after error detection
> Rename a jump label in cfi_amdstd_setup()
> cfi_cmdset_0002: Add some spaces for better code readability
> cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword()
> cfi_cmdset_0002: Use common error handling code in do_write_oneword()
> Use kcalloc() in cfi_ppb_unlock()
> Use kmalloc_array() in cfi_staa_setup()
> Use common error handling code in cfi_staa_setup()
> cfi_cmdset_0020: Add some spaces for better code readability

You know what, I almost considered reviewing this series, but I had a
look at the commit titles (and the sort of things you're
'fixing/improving') and decided to google your name instead.

It seems that you've already sent quite a lot of so-called
'cleanup/improvement' patches, and most of the time you don't understand
what you're doing.
Maybe it's time for you to stop using static analysis tools and start
spending time on real stuff.

Note that I'm usually not against cleanup/coding-style patches, but it
really seems that you're only interested in getting as much patches as
you can in mainline, no matter what they do.

Sorry, that's a NACK on my side. Let's see of other MTD maintainers are
willing to take the time to review your patches. And BTW, when you
submit something, you could at least have a look at previous commits
touching the same files/directories and try to match the subsystem
prefix ("mtd: cfi_cmdset: ", "mtd: cfi: " or "mtd: chips: cfi: ").

Regards,

Boris

>
> drivers/mtd/chips/cfi_cmdset_0001.c | 165 +++++++++++++++++++-----------------
> drivers/mtd/chips/cfi_cmdset_0002.c | 110 +++++++++++++-----------
> drivers/mtd/chips/cfi_cmdset_0020.c | 127 ++++++++++++++-------------
> 3 files changed, 214 insertions(+), 188 deletions(-)
>

\
 
 \ /
  Last update: 2017-01-11 22:57    [W:0.084 / U:2.972 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site