lkml.org 
[lkml]   [2017]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with nandc instead of nand
From
Date
On 01/11/2017 01:39 PM, Boris Brezillon wrote:
> On Wed, 11 Jan 2017 13:09:09 +0100
> Marek Vasut <marek.vasut@gmail.com> wrote:
>
>> On 01/11/2017 08:46 AM, Boris Brezillon wrote:
>>> On Tue, 10 Jan 2017 20:08:23 +0100
>>> Marek Vasut <marek.vasut@gmail.com> wrote:
>>>
>>>> On 11/21/2016 01:45 PM, Boris Brezillon wrote:
>>>>> Some raw NAND function names conflict with names defined in nand.h.
>>>>> Prefix all those functions with nandc (for nand chip) instead of nand so
>>>>> we can include nand.h from rawnand.h
>>>>>
>>>>> Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>
>>>>
>>>> Nit, nand and nandc is quite confusing, why not call it nand_chip in full?
>>>>
>>>
>>> Indeed, the name is confusing as hell, I just tried to keep it
>>> short but that's probably not a good idea.
>>> Maybe I should just prefix/suffix the new functions with nanddev instead
>>> of changing the existing ones. What do you think?
>>
>> That'd be less intrusive, but tbh, if the name is descriptive enough, I
>> don't care either way. What does 'nanddev' imply though ? NAND device as
>> in physical device or chip or just a kernel device object ? :-)
>>
>
> Physical device, but it's also exposed as a kernel dev object by the
> MTD layer.

So I guess nandchip if it's supposed to be physical device then.

--
Best regards,
Marek Vasut

\
 
 \ /
  Last update: 2017-01-11 14:13    [W:0.037 / U:4.468 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site