lkml.org 
[lkml]   [2016]   [Aug]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [Intel-wired-lan] e1000e: PHY cann't be initialized correctly on some I218 controllers
From
Date


On 8/7/2016 11:56, Denis Turischev wrote:
> Hi Raanan,
>
> On 08/04/2016 07:18 PM, Raanan Avargil wrote:
>> It is hard to determine what is exactly the problem here and what causes the -3 error, but this is not the place to perform hw reset and retry to init the phy.
> I agree that may be this is not the correct place for hw reset, can you advice about another solution?
>
> It works, not only for me, for example it helps here:
> http://www.linux.org.ru/forum/linux-hardware/10268216
>
> Another fact that Windows drivers work fine with the same hw.
>
> Denis
>

Hi Denis,

More suitable place to retry init the device would be in probe function.
However, we haven't seen initialization issues like this on i218.

Adding Aaron.

@Aaron - have you seen initialization errors on i218 devices?

Raanan
---------------------------------------------------------------------
Intel Israel (74) Limited

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

\
 
 \ /
  Last update: 2016-08-09 17:41    [W:0.110 / U:0.268 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site