lkml.org 
[lkml]   [2016]   [Aug]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 5/8] cris-cryptocop: Move an assignment for the variable "nooutpages" in cryptocop_ioctl_process()
From
Date
>> +++ b/arch/cris/arch-v32/drivers/cryptocop.c
>> @@ -2469,7 +2469,7 @@ static int cryptocop_ioctl_process(struct inode *inode, struct file *filp, unsig
>> struct page **inpages = NULL;
>> struct page **outpages = NULL;
>> int noinpages = 0;
>> - int nooutpages = 0;
>> + int nooutpages;
>>
>> struct cryptocop_desc descs[5]; /* Max 5 descriptors are needed, there are three transforms that
>> * can get connected/disconnected on different places in the indata. */
>> @@ -2695,6 +2695,8 @@ static int cryptocop_ioctl_process(struct inode *inode, struct file *filp, unsig
>> err = -ENOMEM;
>> goto free_inpages;
>> }
>> + } else {
>> + nooutpages = 0;
>
> Why is it better? 4 characters have becomes 2 lines.

I suggest to express in a more precise way where this variable is needed actually.

* It would also be an update candidate for the refactoring "Reduce the scope of a variable", wouldn't it?

* Or would the refactoring "Split the implementation of a function into further functions" more appropriate here?

Regards,
Markus

\
 
 \ /
  Last update: 2016-09-17 09:58    [W:0.492 / U:0.292 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site