[lkml]   [2016]   [Aug]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH RFC V3.5] leds: trigger: Introduce an USB port trigger
On 25 August 2016 at 10:03, Jacek Anaszewski <> wrote:
> On 08/24/2016 07:52 PM, Rafał Miłecki wrote:
>> From: Rafał Miłecki <>
>> This commit adds a new trigger responsible for turning on LED when USB
>> device gets connected to the specified USB port. This can can useful for
>> various home routers that have USB port(s) and a proper LED telling user
>> a device is connected.
>> The trigger gets its documentation file but basically it just requires
>> specifying USB port in a Linux format (e.g. echo 1-1 > new_port).
>> During work on this trigger there was a plan to add DT bindings for it,
>> but there wasn't an agreement on the format yet. This can be worked on
>> later, a sysfs interface is needed anyway for platforms not using DT.
>> Signed-off-by: Rafał Miłecki <>
>> ---
>> V2: Trying to add DT support, idea postponed as it will take more time
>> to discuss the bindings.
>> V3: Fix typos in commit and Documentation (thanks Jacek!)
>> Use "ports" sysfs file for adding and removing USB ports (thx Jacek)
>> Check if there is USB device connected after adding new USB port
>> Fix memory leak or two
>> V3.5: Fix e-mail address (thanks Matthias)
>> Simplify conditions in usbport_trig_notify (thx Matthias)
>> Make "ports" a subdirectory with file per port, to match one value
>> per file sysfs rule (thanks Greg)
>> As "ports" couldn't be used for adding and removing ports anymore,
>> there are now "new_port" and "remove_port". Having them makes this
>> API also common with e.g. pci and usb buses.
> Now writing new_port with "1-1" produces a file named "1-1" in the
> ports directory with 000 permissions. I think that what Greg had
> on mind by referring to "one value per file" rule was a set of
> files representing ports, like "1-1 1-2 2-1", and each file should be
> readable/writeable.

On the other hand, when I described my idea with "new_port" and
"remove_port", Greg replied with "Maybe", so I'm not sure if he really
got a design you described in his mind.

Greg: could you comment on this sysfs interface, please? :)


 \ /
  Last update: 2016-09-17 09:57    [W:0.061 / U:0.860 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site