lkml.org 
[lkml]   [2016]   [Aug]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
Date

1. use zero-length array to make the code more readable.
2. remove an unused struct member.
3. small error handling improvement to some error cases.

Dexuan Cui (5):
PCI: hv: use zero-length message in struct pci_packet
PCI: hv: use pci_function_description[0] in struct definitions
PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
PCI: hv: hv_compose_msi_msg: handle the 'ret' value
PCI: hv: hv_pci_generic_compl(): handle the error case

drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++---------------------
1 file changed, 29 insertions(+), 27 deletions(-)

--
2.7.4

\
 
 \ /
  Last update: 2016-09-17 09:57    [W:0.047 / U:0.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site