lkml.org 
[lkml]   [2016]   [Aug]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
Date

Hi,

Javier Martinez Canillas <javier@osg.samsung.com> writes:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Assuming this is going through trivial tree:

Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

thanks

> ---
>
> drivers/usb/serial/keyspan_pda.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/serial/keyspan_pda.c b/drivers/usb/serial/keyspan_pda.c
> index 4f7e072e4e00..e49ad0c63ad8 100644
> --- a/drivers/usb/serial/keyspan_pda.c
> +++ b/drivers/usb/serial/keyspan_pda.c
> @@ -30,12 +30,12 @@
> #include <linux/usb/ezusb.h>
>
> /* make a simple define to handle if we are compiling keyspan_pda or xircom support */
> -#if defined(CONFIG_USB_SERIAL_KEYSPAN_PDA) || defined(CONFIG_USB_SERIAL_KEYSPAN_PDA_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_KEYSPAN_PDA)
> #define KEYSPAN
> #else
> #undef KEYSPAN
> #endif
> -#if defined(CONFIG_USB_SERIAL_XIRCOM) || defined(CONFIG_USB_SERIAL_XIRCOM_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_XIRCOM)
> #define XIRCOM
> #else
> #undef XIRCOM
> --
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html

--
balbi
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2016-09-17 09:57    [W:0.055 / U:0.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site