lkml.org 
[lkml]   [2016]   [Aug]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 19/51] x86/entry/32: rename 'error_code' to 'common_exception'
On Sun, Aug 14, 2016 at 12:40:03AM -0700, Andy Lutomirski wrote:
> On Fri, Aug 12, 2016 at 7:28 AM, Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> > The 'error_code' label is awkwardly named, especially when it shows up
> > in a stack trace. Move it to its own local function and rename it to
> > 'common_exception', analagous to the existing 'common_interrupt'.
> >
> > This also makes related stack traces more sensible.
>
> This is okay with me. You could also call it "error_entry" for
> consistency with x86_64.

On x86_64, error_entry is just a helper function which doesn't call the
C handler, and so it doesn't usually show up in the stack trace. So its
scope is quite different from error_code/common_exception.

--
Josh

\
 
 \ /
  Last update: 2016-09-17 09:56    [W:1.993 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site