lkml.org 
[lkml]   [2016]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Regression between rc2 and rc6: ACPI EC problems
Date
On Thursday, July 07, 2016 12:26:49 AM Zheng, Lv wrote:
> Hi, Rafael
>
> > From: Rafael J. Wysocki [mailto:rjw@rjwysocki.net]
> > Sent: Thursday, July 7, 2016 5:29 AM
> > Subject: Re: Regression between rc2 and rc6: ACPI EC problems
> >
> > On Wednesday, July 06, 2016 11:14:11 PM Wolfram Sang wrote:
> > > Hi,
> > >
> > > when upgrading from v4.7-rc2 to rc6 on my Dell Mini 9, battery and
> > > temperature status info got bogus. Here is the major change between
> > the
> > > boot logs:
> > >
> > > ACPI : EC: EC stopped
> > > ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for
> > [EmbeddedControl] (20160422/evregion-300)
> > > ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._REG]
> > (Node f5d09870), AE_BAD_PARAMETER (20160422/psparse-542)
> > > ACPI Exception: AE_BAD_PARAMETER, from region _REG,
> > [EmbeddedControl] (20160422/evregion-397)
> > > ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for
> > [EmbeddedControl] (20160422/evregion-300)
> > > ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._REG]
> > (Node f5d09870), AE_BAD_PARAMETER (20160422/psparse-542)
> > > ACPI Exception: AE_BAD_PARAMETER, from region _REG,
> > [EmbeddedControl] (20160422/evregion-397)
> > > ACPI : EC: GPE = 0x19, I/O: command/status = 0x66, data = 0x62
> > > ACPI : EC: EC started
> [Lv Zheng]
> This is a known order issue that ACPICA executes _REG(DISCONENCT) after removing the opregion handler.
> But this issue is not a function failure, it only generates error garbage in the kernel log.
> So we didn't fix it in a hurry.
>
> There is another order issue detected in the same Bugzilla entry that:
> _REG(CONNECT/DISCONNECT) shouldn't be invoked for SystemMemory/SystemIo and PCI_Config that under a PCI root bus containing _BBN method.
> Which is also proven by the Windows behavior and spec definitions.
>
> I was planning to fix the both issues in the ACPICA upstream.
> The bug is here for your reference:
> https://bugzilla.kernel.org/show_bug.cgi?id=102421
>
> For now, since this is just a non-function-failure error report, we can ignore it.
> Because sometimes, when there are several problems related, we have to make a choice to fix one of them first.

Well, please look at the report again. It says:

"when upgrading from v4.7-rc2 to rc6 on my Dell Mini 9, battery and
temperature status info got bogus".

So, it very much *is* a functional issue and I'm not going to ignore it.

Thanks,
Rafael

\
 
 \ /
  Last update: 2016-07-07 03:21    [W:0.044 / U:10.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site