[lkml]   [2016]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC v0 3/8] firmware: Factor out firmware load helpers
> It's somewhat odd to me that the structure is "firmware_stat" but most
> of the functions are "fw_loading_*". That seems inconsistent for a
> structure that is (currently) only used by these functions.

I agree, my proposal is odd.

> I would personally do either:
> a) "struct fw_load_status" and "fw_load_*()"
> or
> b) "struct firmware_load_stat" and "firmware_load_*()"
> I'd also change the function names from "loading" -> "load", similar to
> how userland has read(2), not reading(2).

a) sounds good to me, because fw_load_ should be long enough prefix.


 \ /
  Last update: 2016-07-29 09:01    [W:0.096 / U:0.856 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site