lkml.org 
[lkml]   [2016]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] locking/percpu-rwsem: Introduce bias knob
On 07/15, Paul E. McKenney wrote:
>
> On Fri, Jul 15, 2016 at 03:27:09PM +0200, Oleg Nesterov wrote:
> >
> > Heh ;) I too think it should be renamed. I'd suggest
> >
> > __rcu_sync_enter(rss);
> >
> > although I do not really mind and agree with any name.
>
> Hmmm... Why not just move the checks out into the caller? That
> would make the intent much more clear.

Hmm. which caller?

Oleg.

\
 
 \ /
  Last update: 2016-07-15 16:21    [W:0.121 / U:2.900 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site