lkml.org 
[lkml]   [2016]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] locking/percpu-rwsem: Introduce bias knob
On Fri, Jul 15, 2016 at 03:27:09PM +0200, Oleg Nesterov wrote:
> On 07/14, Peter Zijlstra wrote:
> >
> > On Thu, Jul 14, 2016 at 08:43:51PM +0200, Oleg Nesterov wrote:
> > >
> > > Oh well... I personally do not think this is what we want... Can't
> > > we just add the stupid rcu_sync_enter() into cgroup_init() at least
> > > for now? Yes, this means the unnecessary .sync() at boot time, but
> > > it will go away after cleanups I am going to send.
> >
> > Something like so then?
>
> OK, agreed,
>
> > ---
> > --- a/include/linux/rcu_sync.h
> > +++ b/include/linux/rcu_sync.h
> > @@ -59,6 +59,7 @@ static inline bool rcu_sync_is_idle(stru
> > }
> >
> > extern void rcu_sync_init(struct rcu_sync *, enum rcu_sync_type);
> > +extern void rcu_sync_sabotage(struct rcu_sync *);
> > extern void rcu_sync_enter(struct rcu_sync *);
> > extern void rcu_sync_exit(struct rcu_sync *);
> > extern void rcu_sync_dtor(struct rcu_sync *);
> > --- a/kernel/cgroup.c
> > +++ b/kernel/cgroup.c
> > @@ -5609,6 +5609,8 @@ int __init cgroup_init(void)
> > BUG_ON(cgroup_init_cftypes(NULL, cgroup_dfl_base_files));
> > BUG_ON(cgroup_init_cftypes(NULL, cgroup_legacy_base_files));
> >
> > + rcu_sync_sabotage(&cgroup_threadgroup_rwsem.rss);
>
> Heh ;) I too think it should be renamed. I'd suggest
>
> __rcu_sync_enter(rss);
>
> although I do not really mind and agree with any name.

Hmmm... Why not just move the checks out into the caller? That
would make the intent much more clear.

Thanx, Paul

> Hopefully I'll send some cleanups soon, rcu_sync_enter() will be
> re-implemented as
>
> rcu_sync_enter(rss)
> {
> if (__rcu_sync_enter(rss))
> __rcu_sync_wait(rss);
> }
>
> > + * rcu_sync_sabotage() - Sabotage a fresh rcu_sync instance
> > + * @rsp: Pointer to rcu_sync structure to be sabotaged
> > + *
> > + * Must be called after rcu_sync_init() and before first use.
>
> OK. And after those cleanups __rcu_sync_enter() can be called at any
> time.
>
> Oleg.
>

\
 
 \ /
  Last update: 2016-07-15 16:21    [W:0.085 / U:0.872 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site