lkml.org 
[lkml]   [2016]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v11 2/3] perf config: Reimplement perf_config() introducing new perf_config__init() and perf_config__finish()
Em Thu, Jun 23, 2016 at 10:03:39PM +0900, Taeung Song escreveu:
> +/**
> + * perf_config_sections__for_each - iterate thru all the sections
> + * @list: list_head instance to iterate
> + * @section: struct perf_config_section iterator
> + */
> +#define perf_config_sections__for_each(list, section) \
> + list_for_each_entry(section, list, node)
> +

I was almost applying this but then there is a little detail, which is
that it is a goal to make the tools/ code look as much as kernel code as
possible, to encourage kernel developers to contribute to the tools
codebase and also to expose userspace developers to kernel practices.

With that said, please rename these for_each macros to for_each_entry,
i.e.:

perf_config_sections__for_each_entry()
perf_config_items__for_each_entry()

As for_each and for_each_entry both exist in the kernel and have well
know semantics that we want to keep.

Probably there are cases in tools/ where we break this rule, I'll check
and fix.

Thanks,

- Arnaldo

> +/**
> + * perf_config_items__for_each - iterate thru all the items
> + * @list: list_head instance to iterate
> + * @item: struct perf_config_item iterator
> + */
> +#define perf_config_items__for_each(list, item) \
> + list_for_each_entry(item, list, node)
> +
> +/**
> + * perf_config_set__for_each - iterate thru all the config section-item pairs
> + * @set: evlist instance to iterate
> + * @section: struct perf_config_section iterator
> + * @item: struct perf_config_item iterator
> + */
> +#define perf_config_set__for_each(set, section, item) \
> + perf_config_sections__for_each(&set->sections, section) \
> + perf_config_items__for_each(&section->items, item)
>
> #endif /* __PERF_CONFIG_H */
> --
> 2.5.0

\
 
 \ /
  Last update: 2016-06-23 16:21    [W:3.481 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site