lkml.org 
[lkml]   [2016]   [May]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/3] of: generic infrastructure fixes
Date
The first patch renames the *_node_sysfs methods to _node_post since
this is more accurate when more work takes place besides sysfs
tweaking when the next patch is using a hashtable for phandles.
This is a win for very large blobs with a large number of phandles.
Current we use an exhaustive search which is not optimal at all.

Finally, a long standing request of applied overlays populating
the symbol list is implemented; this allows staggered overlay
application with a symbol from a previous overlay being used
by another after it.

Pantelis Antoniou (3):
of: rename *_node_sysfs to _node_post
of: Support hashtable lookups for phandles
of: overlay: Pick up label symbols from overlays.

drivers/of/base.c | 39 +++++++++++++++---
drivers/of/dynamic.c | 18 ++++++---
drivers/of/of_private.h | 35 ++++++++++++++++-
drivers/of/overlay.c | 102 ++++++++++++++++++++++++++++++++++++++++++++++++
drivers/of/unittest.c | 4 +-
include/linux/of.h | 2 +
6 files changed, 186 insertions(+), 14 deletions(-)

--
1.7.12

\
 
 \ /
  Last update: 2016-05-09 20:21    [W:0.113 / U:0.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site