lkml.org 
[lkml]   [2016]   [May]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] mmc: tegra: Disable UHS-I modes for tegra30
From
Date

On 10/05/16 08:09, Lucas Stach wrote:
> Hi Jon,
>
> Am Montag, den 09.05.2016, 16:15 +0100 schrieb Jon Hunter:
>> Support for SD cards is not working on the Tegra30 Beaver board and
>> on
>> boot the following error message is seen if an SD card is present:
>>
>> mmc0: error -110 whilst initialising SD card
>>
> Can you please tell me what kind of SD card you used and at which point
> in the initialization it is hanging? I've tested this change on Beaver
> and haven't seen any failures after I implemented the memcomppad
> calibration.

Yes it is an SDHC 4GB I believe. The board is remote and so I have not
seen the exact card. However, here are some more details from sysfs:

root@(none):/# cat /sys/class/mmc_host/mmc0/mmc0\:aaaa/name
SS04G
root@(none):/# cat /sys/class/mmc_host/mmc0/mmc0\:aaaa/csd
400e00325b5900001d8a7f800a404000
root@(none):/# cat /sys/class/mmc_host/mmc0/mmc0\:aaaa/cid
03534453533034478029b1301800f900
root@(none):/# cat /sys/class/mmc_host/mmc0/mmc0\:aaaa/oemid
0x5344
root@(none):/# cat /sys/class/mmc_host/mmc0/mmc0\:aaaa/manfid
0x000003

>> In addition to this, Tegra30 is also randomly hanging during system
>> suspend when entering and is caused by the Tegra SDHCI driver.
>
> I'll have a look at this soonish.

Thanks. I think I have mentioned this before, but I run a loop test
for example ...

count=0; while [ $count -lt 100 ]; do rtcwake -d rtc0 -m mem -s 3; echo
Suspend iteration $count; count=`expr $count + 1`; done

Cheers
Jon

\
 
 \ /
  Last update: 2016-05-10 13:41    [W:0.083 / U:4.764 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site