lkml.org 
[lkml]   [2016]   [Apr]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH V10 2/6] mfd: max77620: add core driver for MAX77620/MAX20024
On Wed, 27 Apr 2016, Laxman Dewangan wrote:

>
> On Wednesday 27 April 2016 08:49 PM, Lee Jones wrote:
> >On Wed, 30 Mar 2016, Laxman Dewangan wrote:
> >
> >>+#define MAX77620_MFD_CELL_RES(_name, _res) \
> >>+ { \
> >>+ .name = (_name), \
> >>+ .resources = (_res), \
> >>+ .num_resources = ARRAY_SIZE((_res)), \
> >>+ }
> >I'm *still* not accepting this.
> >
> >>+
> >>+static struct mfd_cell max20024_children[] = {
> >>+ MAX77620_MFD_CELL_NAME("max20024-pinctrl"),
> >>+ MAX77620_MFD_CELL_RES("max20024-gpio", gpio_resources),
> >>+ MAX77620_MFD_CELL_NAME("max20024-pmic"),
> >>+ MAX77620_MFD_CELL_RES("max77620-rtc", rtc_resources),
> >>+ MAX77620_MFD_CELL_RES("max20024-power", power_resources),
> >>+ MAX77620_MFD_CELL_NAME("max20024-watchdog"),
> >>+ MAX77620_MFD_CELL_NAME("max20024-clock"),
> >>+};
> >If you want this submission to be accepted this cycle, you're going to
> >have to convert this to the traditional way of defining MFD children.
>
> Yaah, I want to have this in current cycle.
> Will it be fine as follows? (To have quick agreement)
>
> static const struct mfd_cell max77620_children[] = {
> {
> .name = "max77620-pinctrl",
> }, {
> .name = "max77620-gpio",
> .resource = gpio_resources,
> .num_resources = ARRAY_SIZE(gpio_resources),
> }, {
> /* and so on */
> },
> };

Yes. Although, if there are no run-time ordering dependencies, I
usually like to a) have the one line entries on one line i.e.

{ .name = "max77620-pinctrl" }

... and b) for all the one line entries to be grouped together and
the multi line ones grouped together as well.

> >
> >>+ if (x >= tperiod)
> >>+ return i;
> >>+ }
> >>+
> >>+ return i;
> >>+}
> >>+
> >>+static int max77620_config_fps(struct max77620_chip *chip,
> >>+ struct device_node *fps_np)
> >Lots of mention of 'FPS' here, but noting to so what that is?
> >
> >What does FPS stand for and what does the FPS do?
>
> FPS is Flexible Power Sequence. It is explained in DT binding doc.
>
> However, I will document the function to make it more clear in next
> revision.
>

--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog

\
 
 \ /
  Last update: 2016-04-28 09:41    [W:0.102 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site