lkml.org 
[lkml]   [2016]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH/RFC v2] perf core: Allow setting up max frame stack depth via sysctl
On Mon, Apr 25, 2016 at 04:22:29PM -0300, Arnaldo Carvalho de Melo wrote:
> Em Mon, Apr 25, 2016 at 01:27:06PM -0300, Arnaldo Carvalho de Melo escreveu:
> > Em Mon, Apr 25, 2016 at 01:14:25PM -0300, Arnaldo Carvalho de Melo escreveu:
> > > Em Fri, Apr 22, 2016 at 03:18:08PM -0700, Alexei Starovoitov escreveu:
> > > > right... and looking into it further, realized that the patch is broken,
> > > > since get_callchain_entry() is doing:
> > > > return &entries->cpu_entries[cpu][*rctx];
> > > > whereas it should be dynamic offset based on sysctl_perf_event_max_stack*8
> > > > So definitely needs another respin.
>
> > struct perf_callchain_entry {
> > __u64 nr;
> > __u64 ip[0]; /* /proc/sys/kernel/perf_event_max_stack */
> > };
>
> > But perf_callchain_entry->ip is not a pointer... Got it ;-\
>
> This is what I am building now, a patch on top of the previous, that
> will be combined and sent as v3, if I don't find any more funnies:
>
> diff --git a/kernel/events/callchain.c b/kernel/events/callchain.c
> index 6fe77349fa9d..40657892a7e0 100644
> --- a/kernel/events/callchain.c
> +++ b/kernel/events/callchain.c
> @@ -20,11 +20,10 @@ struct callchain_cpus_entries {
>
> int sysctl_perf_event_max_stack __read_mostly = PERF_MAX_STACK_DEPTH;
>
> -static size_t perf_callchain_entry__sizeof(void)
> -{
> - return sizeof(struct perf_callchain_entry) +
> - sizeof(__u64) * sysctl_perf_event_max_stack;
> -}
> +#define __perf_callchain_entry_size(entries) \
> + (sizeof(struct perf_callchain_entry) + sizeof(__u64) * entries)
> +
> +static size_t perf_callchain_entry_size __read_mostly = __perf_callchain_entry_size(PERF_MAX_STACK_DEPTH);
>
> static DEFINE_PER_CPU(int, callchain_recursion[PERF_NR_CONTEXTS]);
> static atomic_t nr_callchain_events;
> @@ -81,7 +80,7 @@ static int alloc_callchain_buffers(void)
> if (!entries)
> return -ENOMEM;
>
> - size = perf_callchain_entry__sizeof() * PERF_NR_CONTEXTS;
> + size = perf_callchain_entry_size * PERF_NR_CONTEXTS;
>
> for_each_possible_cpu(cpu) {
> entries->cpu_entries[cpu] = kmalloc_node(size, GFP_KERNEL,
> @@ -155,7 +154,8 @@ static struct perf_callchain_entry *get_callchain_entry(int *rctx)
>
> cpu = smp_processor_id();
>
> - return &entries->cpu_entries[cpu][*rctx];
> + return (((void *)&entries->cpu_entries[cpu][0]) +
> + (*rctx * perf_callchain_entry_size));

I think the following would be easier to read:

+ return (void *)entries->cpu_entries[cpu] +
+ *rctx * perf_callchain_entry_size;
?
if didn't mixed up the ordering...

and probably we could do the math on the spot instead of introducing
perf_callchain_entry_size global variable?

\
 
 \ /
  Last update: 2016-04-25 22:21    [W:0.076 / U:0.580 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site