lkml.org 
[lkml]   [2016]   [Apr]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 10/15] __d_add(): don't drop/regain ->d_lock
From
Date
On Sat, 2016-04-16 at 01:55 +0100, Al Viro wrote:
> From: Al Viro <viro@zeniv.linux.org.uk>
>
> Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
> ---
>  fs/dcache.c | 14 +++++++++++---
>  1 file changed, 11 insertions(+), 3 deletions(-)
>
> diff --git a/fs/dcache.c b/fs/dcache.c
> index e9de4d9..33cad8a 100644
> --- a/fs/dcache.c
> +++ b/fs/dcache.c
> @@ -2363,11 +2363,19 @@ EXPORT_SYMBOL(d_rehash);
>  
>  static inline void __d_add(struct dentry *dentry, struct inode *inode)
>  {
> + spin_lock(&dentry->d_lock);
>   if (inode) {
> - __d_instantiate(dentry, inode);
> + unsigned add_flags = d_flags_for_inode(inode);
> + hlist_add_head(&dentry->d_u.d_alias, &inode->i_dentry);
> + raw_write_seqcount_begin(&dentry->d_seq);
> + __d_set_inode_and_type(dentry, inode, add_flags);
> + raw_write_seqcount_end(&dentry->d_seq);
> + __fsnotify_d_instantiate(dentry);

Should the above be a new __d_instantiate_locked instead of open-coding
it?

> + }
> + _d_rehash(dentry);
> + spin_unlock(&dentry->d_lock);
> + if (inode)
>   spin_unlock(&inode->i_lock);
> - }
> - d_rehash(dentry);
>  }
>  
>  /**
--
Jeff Layton <jlayton@poochiereds.net>

\
 
 \ /
  Last update: 2016-04-24 20:21    [W:0.119 / U:0.244 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site