lkml.org 
[lkml]   [2016]   [Apr]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 0/2] Align mmap address for DAX pmd mappings
From
Date

On 4/21/2016 8:22 PM, Matthew Wilcox wrote:
> On Thu, Apr 21, 2016 at 07:43:39PM -0400, Toshi Kani wrote:
>> On 4/21/2016 4:21 PM, Mike Kravetz wrote:
>>> Might want to keep the future possibility of PUD_SIZE THP in mind?
>> Yes, this is why the func name does not say 'pmd'. It can be extended to
>> support
>> PUD_SIZE in future.
> Sure ... but what does that look like? I think it should look a little
> like this:

Yes, I had something similar in mind, too. Do you want me to use this
version without the call with PUD_SIZE?

>
> unsigned long __thp_get_unmapped_area(struct file *filp, unsigned long len,
> loff_t off, unsigned long flags, unsigned long size);
> {
> unsigned long addr;
> loff_t off_end = off + len;
> loff_t off_align = round_up(off, size);
> unsigned long len_size;
>
> if ((off_end <= off_align) || ((off_end - off_align) < size))
> return NULL;
>
> len_size = len + size;
> if ((len_size < len) || (off + len_size) < off)
> return NULL;
>
> addr = current->mm->get_unmapped_area(filp, NULL, len_size,
> off >> PAGE_SHIFT, flags);
> if (IS_ERR_VALUE(addr))
> return NULL;
>
> addr += (off - addr) & (size - 1);
> return addr;
> }
>
> unsigned long thp_get_unmapped_area(struct file *filp, unsigned long addr,
> unsigned long len, unsigned long pgoff, unsigned long flags)
> {
> loff_t off = (loff_t)pgoff << PAGE_SHIFT;
>
> if (addr)
> goto out;
> if (IS_DAX(filp->f_mapping->host) && !IS_ENABLED(CONFIG_FS_DAX_PMD))
> goto out;
> /* Kirill, please fill in the right condition here for THP pagecache */
>
> addr = __thp_get_unmapped_area(filp, len, off, flags, PUD_SIZE);
> if (addr)
> return addr;
> addr = __thp_get_unmapped_area(filp, len, off, flags, PMD_SIZE);
> if (addr)
> return addr;
>
> out:
> return current->mm->get_unmapped_area(filp, addr, len, pgoff, flags);
> }
>
> By the way, I added an extra check here, when we add len and size
> (PMD_SIZE in the original), we need to make sure that doesn't wrap.
> NB: I'm not even compiling these suggestions, just throwing them out
> here as ideas to be criticised.

Yes, I agree with the extra check. Thanks for pointing this out.

>
> Also, len_size is a stupid name, but I can't think of a better one.

How about len_pad?

Thanks,
-Toshi

\
 
 \ /
  Last update: 2016-04-22 03:21    [W:0.044 / U:51.696 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site