lkml.org 
[lkml]   [2016]   [Apr]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall()
On Tue, Apr 19, 2016 at 01:15:30PM +0200, Ingo Molnar wrote:
> So I'd suggest the following renames to harmonize these concepts:
>
> - CONFIG_IA32_EMULATION => CONFIG_X86_32_ABI
> this lines up nicely with: CONFIG_X86_X32_ABI

Except that the only difference now is the "X" in the strings. So one
would need more coffee when staring at those. :)

>
> - is_ia32_syscall() -> is_x86_32_syscall()
> - is_x32_syscall() -> is_x86_x32_syscall()
>
> - is_compat_syscall() remains as-is.
>
> ... thoughts?

Still, getting those names streamlined and logical is a step in the
right direction IMO.

--
Regards/Gruss,
Boris.

ECO tip #101: Trim your mails when you reply. Srsly.

\
 
 \ /
  Last update: 2016-04-19 13:41    [W:0.132 / U:0.444 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site