lkml.org 
[lkml]   [2016]   [Apr]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 02/10] perf tools: Add perf_data_file__switch() helper
Em Fri, Apr 15, 2016 at 12:41:08PM +0200, Jiri Olsa escreveu:
> On Wed, Apr 13, 2016 at 08:21:05AM +0000, Wang Nan wrote:
> > perf_data_file__switch() closes current output file, renames it, then
> > open a new one to continue recording. It will be used by perf record
> > to split output into multiple perf.data files.
> >
> > Signed-off-by: Wang Nan <wangnan0@huawei.com>
> > Signed-off-by: He Kuang <hekuang@huawei.com>
> > Cc: Arnaldo Carvalho de Melo <acme@redhat.com>
> > Cc: Jiri Olsa <jolsa@kernel.org>
> > Cc: Masami Hiramatsu <masami.hiramatsu.pt@hitachi.com>
> > Cc: Namhyung Kim <namhyung@kernel.org>
> > Cc: Zefan Li <lizefan@huawei.com>
> > Cc: pi3orama@163.com
> > ---
> > tools/perf/util/data.c | 41 +++++++++++++++++++++++++++++++++++++++++
> > tools/perf/util/data.h | 11 ++++++++++-
> > 2 files changed, 51 insertions(+), 1 deletion(-)
> >
> > diff --git a/tools/perf/util/data.c b/tools/perf/util/data.c
> > index 1921942..be835161 100644
> > --- a/tools/perf/util/data.c
> > +++ b/tools/perf/util/data.c
> > @@ -136,3 +136,44 @@ ssize_t perf_data_file__write(struct perf_data_file *file,
> > {
> > return writen(file->fd, buf, size);
> > }
> > +
> > +int perf_data_file__switch(struct perf_data_file *file,
> > + const char *postfix,
> > + size_t pos, bool at_exit)
>
> could you please rename at_exit to reopen
>
> I guess you follow the record object's at_exit naming,
> but 'reopen' seems more clear to me
>

I'll rename this, if not yet pushed to Ingo, checking...

- Arnaldo
> jirka

\
 
 \ /
  Last update: 2016-04-15 18:21    [W:0.285 / U:0.056 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site