lkml.org 
[lkml]   [2016]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v2] x86/setup: Merge {early_,}reserve_initrd() to one function
Hello Ingo,

On Tue, Feb 9, 2016 at 3:16 PM, Ingo Molnar <mingo@kernel.org> wrote:
>
> So I don't think the code got easier to understand - in particular the
> memblock_reserve()/free() pattern, depending on a flag value, is confusing.
>
> The duplication is there - but please factor it out into a helper structure
> ('struct ramdisk') and a helper function that sets up the structure.

What if instead of `struct ramdisk`, we will move all definitions/check from
the early_reserve_initrd to the setup_arch() and than will pass these values
to the reserve_initrd()?

\
 
 \ /
  Last update: 2016-02-09 13:01    [W:0.050 / U:3.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site