lkml.org 
[lkml]   [2016]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/2] dax: pass bdev argument to dax_clear_blocks()
On Mon, Feb 08, 2016 at 04:17:25PM +1100, Dave Chinner wrote:
> On Sun, Feb 07, 2016 at 06:44:09PM -0700, Ross Zwisler wrote:
> > On Mon, Feb 08, 2016 at 09:03:29AM +1100, Dave Chinner wrote:
> > > On Sun, Feb 07, 2016 at 12:19:12AM -0700, Ross Zwisler wrote:
> > > > dax_clear_blocks() needs a valid struct block_device and previously it was
> > > > using inode->i_sb->s_bdev in all cases. This is correct for normal inodes
> > > > on mounted ext2, ext4 and XFS filesystems, but is incorrect for DAX raw
> > > > block devices and for XFS real-time devices.
> > > >
> > > > Instead, have the caller pass in a struct block_device pointer which it
> > > > knows to be correct.
> > > ....
> > > > diff --git a/fs/xfs/xfs_bmap_util.c b/fs/xfs/xfs_bmap_util.c
> > > > index 07ef29b..f722ba2 100644
> > > > --- a/fs/xfs/xfs_bmap_util.c
> > > > +++ b/fs/xfs/xfs_bmap_util.c
> > > > @@ -73,9 +73,11 @@ xfs_zero_extent(
> > > > xfs_daddr_t sector = xfs_fsb_to_db(ip, start_fsb);
> > > > sector_t block = XFS_BB_TO_FSBT(mp, sector);
> > > > ssize_t size = XFS_FSB_TO_B(mp, count_fsb);
> > > > + struct inode *inode = VFS_I(ip);
> > > >
> > > > if (IS_DAX(VFS_I(ip)))
> > > > - return dax_clear_blocks(VFS_I(ip), block, size);
> > > > + return dax_clear_blocks(inode, xfs_find_bdev_for_inode(inode),
> > > > + block, size);
> > >
> > > Get rid of the local inode variable and use VFS_I(ip) like the code
> > > originally did. Do not change code that is unrelated to the
> > > modifcation being made, especially when it results in making
> > > the code an inconsistent mess of mixed pointer constructs....
> >
> > The local 'inode' variable was added to avoid multiple calls for VFS_I() for
> > the same 'ip'.
>
> My point is you didn't achieve that. The end result of your patch
> is:
>
> struct inode *inode = VFS_I(ip);
>
> if (IS_DAX(VFS_I(ip)))
> return dax_clear_blocks(inode, xfs_find_bdev_for_inode(inode),
> block, size);
>
> So now we have a local variable, but we still have 2 calls to
> VFS_I(ip). i.e. this makes the code harder to read and understand
> than before for no benefit.

*facepalm* Yep, thanks for the correction.

\
 
 \ /
  Last update: 2016-02-08 17:01    [W:0.060 / U:0.076 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site