lkml.org 
[lkml]   [2016]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject[PATCH v4 0/4] Fix ordering of ftrace/livepatch calls on module load and unload
    Date
    As explained here [1], livepatch modules are failing to initialize properly
    because the ftrace coming module notifier (which calls
    ftrace_module_enable()) runs *after* the livepatch module notifier (which
    enables the patch(es)). Thus livepatch attempts to apply patches to
    modules before ftrace_module_enable() is even called for the corresponding
    module(s). As a result, patch modules break. Ftrace code must run before
    livepatch on module load, and the reverse is true on module unload.

    For ftrace and livepatch, order of initialization (plus exit/cleanup code) is
    important for loading and unloading modules, and using module notifiers to
    perform this work is not ideal since it is not always clear what gets called
    when. In this patchset, dependence on the module notifier call chain is removed
    in favor of hard coding the corresponding function calls in the module loader.
    This promotes better code visibility and ensures that ftrace and livepatch code
    get called in the correct order on patch module load and unload.

    Tested the changes with a test livepatch module that patches 9p and nilfs2,
    and verified that the issue described in [1] is fixed.

    Patches are based on linux-next.

    v1:
    https://lkml.kernel.org/g/1454049827-3726-1-git-send-email-jeyu@redhat.com
    v2:
    https://lkml.kernel.org/g/1454375856-27757-1-git-send-email-jeyu@redhat.com
    v3:
    https://lkml.kernel.org/g/1454728097-7106-1-git-send-email-jeyu@redhat.com

    v4:
    - Split part of complete_formation() into prepare_coming_module() to make
    error handling a bit easier
    - Minor tweak: change mod->state to going before calling going notifiers in
    the load_module error path
    - Swapped out obj->mod = NULL assignment in klp_module_coming() for a
    call to klp_free_object_loaded()

    v3:
    - Fix incorrect comments
    - Rename klp_module_{enable,disable} to klp_module_{coming,going}
    - Remove externs from livepatch.h
    - Fix error handling in kernel/module.c

    v2:
    - Instead of splitting the ftrace and livepatch notifiers into coming + going
    notifiers and adjusting their priorities, remove ftrace and livepatch notifiers
    completely and hard-code the necessary function calls in the module loader.

    [1] http://lkml.kernel.org/g/20160128204033.GA32131@packer-debian-8-amd64.digitalocean.com

    Jessica Yu (4):
    modules: split part of complete_formation() into
    prepare_coming_module()
    modules: set mod->state to MODULE_STATE_GOING before going notifiers
    are called
    ftrace/module: remove ftrace module notifier
    livepatch/module: remove livepatch module notifier

    include/linux/ftrace.h | 6 +-
    include/linux/livepatch.h | 9 +++
    kernel/livepatch/core.c | 145 ++++++++++++++++++++++------------------------
    kernel/module.c | 40 ++++++++++---
    kernel/trace/ftrace.c | 36 +-----------
    5 files changed, 116 insertions(+), 120 deletions(-)

    --
    2.4.3

    \
     
     \ /
      Last update: 2016-02-09 06:01    [W:4.301 / U:0.168 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site