lkml.org 
[lkml]   [2016]   [Feb]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 0/3] paravirt: rebrand paravirt_enabled as paravirt_legacy
Date
There's been confusion both in code and by developers as to what
the paravirt_enabled thing means. This sets to clarify this to help
build stronger semantics on our bootup process.

This was originally suggested by Konrad and I included this as part of
a larger patch set [0]. I've decided to break that single rename patch (1/8)
out into a 3 smaller patches to both make it easier to review and to help
with regression testing, should any issues arise.

[0] http://lkml.kernel.org/r/1450217797-19295-1-git-send-email-mcgrof@do-not-panic.com
[1] http://lkml.kernel.org/r/1450217797-19295-2-git-send-email-mcgrof@do-not-panic.com

Luis R. Rodriguez (3):
paravirt: use bool for paravirt_enabled() and paravirt_has_feature()
paravirt: replace direct access to pv_info.paravirt_enabled
paravirt: rename paravirt_enabled to paravirt_legacy

arch/x86/entry/entry_32.S | 2 +-
arch/x86/include/asm/paravirt.h | 10 +++++-----
arch/x86/include/asm/paravirt_types.h | 35 +++++++++++++++++++++++++++++++++--
arch/x86/include/asm/processor.h | 4 ++--
arch/x86/kernel/apm_32.c | 2 +-
arch/x86/kernel/asm-offsets.c | 2 +-
arch/x86/kernel/cpu/intel.c | 2 +-
arch/x86/kernel/cpu/microcode/core.c | 2 +-
arch/x86/kernel/head.c | 2 +-
arch/x86/kernel/kvm.c | 9 +--------
arch/x86/kernel/paravirt.c | 2 +-
arch/x86/kernel/rtc.c | 2 +-
arch/x86/kernel/tboot.c | 2 +-
arch/x86/lguest/boot.c | 4 ++--
arch/x86/mm/dump_pagetables.c | 2 +-
arch/x86/xen/enlighten.c | 2 +-
drivers/pnp/pnpbios/core.c | 2 +-
17 files changed, 55 insertions(+), 31 deletions(-)

--
2.7.0

\
 
 \ /
  Last update: 2016-02-06 06:01    [W:0.079 / U:9.720 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site