lkml.org 
[lkml]   [2016]   [Feb]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 2/3] usb: type-c: USB Type-C Connector System Software Interface
Date
Andy Shevchenko <andy.shevchenko@gmail.com> writes:
> On Wed, Feb 10, 2016 at 3:21 PM, Oliver Neukum <oneukum@suse.com> wrote:
>> On Wed, 2016-02-10 at 13:56 +0200, Andy Shevchenko wrote:
>>> > +out:
>>>
>>> CodingStyle suggests to do a better label naming.
>>
>> Names coming from specs are what they are. There is
>> no place for coding style here.
>
> Yes, and how is it related to C label names?

It did appear as if you were commenting on the case labels since you
quoted two full switch blocks. That's how I read your comment as well.

It's now clear that you somehow mean than "out:" is in conflict with
CodingStyle. It is still very unclear how, and it does not seem like
you intend to make it any clearer since you did not take the opportunity
to explain yourself.

FWIW, I read the CodingStyle recommendation as: use descriptive labels
instead of "foo1", "foo2" etc, where "foo" is typically "err". I do not
see this as conflicting with the use of "err" or "out" when there is a
single such label in a function. The meaning of those labels are very
clear IMHO.

Exactly what is it about "out" that is unclear to you here? Could you
propose a better alternative if you seriously mean that this needs to be
changed?


Bjørn

\
 
 \ /
  Last update: 2016-02-10 16:41    [W:0.122 / U:5.332 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site