lkml.org 
[lkml]   [2016]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 08/14] efivars: Use to_efivar_entry
    Date
    From: Geliang Tang <geliangtang@163.com>

    Use to_efivar_entry() instead of open-coding it.

    Signed-off-by: Geliang Tang <geliangtang@163.com>
    Signed-off-by: Matt Fleming <matt@codeblueprint.co.uk>
    ---
    drivers/firmware/efi/efivars.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/drivers/firmware/efi/efivars.c b/drivers/firmware/efi/efivars.c
    index 756eca8c4cf8..c5b0d2bc1111 100644
    --- a/drivers/firmware/efi/efivars.c
    +++ b/drivers/firmware/efi/efivars.c
    @@ -386,7 +386,7 @@ static const struct sysfs_ops efivar_attr_ops = {

    static void efivar_release(struct kobject *kobj)
    {
    - struct efivar_entry *var = container_of(kobj, struct efivar_entry, kobj);
    + struct efivar_entry *var = to_efivar_entry(kobj);
    kfree(var);
    }

    --
    2.6.2
    \
     
     \ /
      Last update: 2016-02-01 23:41    [W:4.109 / U:0.092 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site