[lkml]   [2016]   [Dec]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCHv6 2/7] printk: rename nmi.c and exported api
On Wed, Dec 21, 2016 at 6:36 AM, Sergey Senozhatsky
<> wrote:
> A preparation patch for printk_safe work. No functional change.
> - rename nmi.c to print_safe.c
> - rename exported functions to have a `printk_safe' prefix.

I dislike this patch.

It's _mostly_ ok, but the nmi naming is nasty.

Either "printk_nmi()" or "printk_safe" is fine, but doing *both* is
stupid and wrong. And you do both in a couple of places.

So please keep the printk_nmi_enter/exit() naming. Because
"printk_safe_nmi_enter/exit()" is just stupid. It's about nmi entry.
The "safe" part is simply an implementation detail.


 \ /
  Last update: 2016-12-21 20:45    [W:0.208 / U:10.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site